RipIt - a command line audio CD ripper
This page in
Installation
..::RipIT 4.0.0 (beta)::..

Some hints for installing the script can be found below.
Ripit uses some additional perl-mudules which need to be installed. Although Ripit informs the operator about missing modules, the modules needed are the following:

  • CDDB_get
  • LWP::Simple
  • XML::Simple
  • Digest::MD5
  • Unicode::UCD
  • Text::Unidecode
  • MP3::Tag
  • MIME::Base64
  • WebService::MusicBrainz
  • MusicBrainz::DiscID

Please test the beta version 4.0.0_beta20140301 released on March 17th 2014 and give feedback. Even a single line telling me that everything is fine would be appreciated!


Tarballs


RPMs for openSUSE 13.1



..::RipIT 3.9.0 (STABLE)::..

The latest stable version of RipIT is 3.9.0 (released January 29th 2012):


Tarballs

You can expand them with the following commands:

tar xvvfj ripit-3.9.0.tar.bz2

or

tar xvvfz ripit-3.9.0.tar.gz

Change to the directory and type as root:

ripstation:/path/to/ripit-3.9.0# make install

Please note: the new Makefile installs RipIT in the directory /usr/local/bin/ and not in /usr/bin/anymore. Possible older versions have to be deleted from /usr/bin/ using: rm /usr/bin/.


RPMs for openSUSE 11.1

One can find more rpms packed for different distros here. Thanks to Frank!

After downloading use following command to check the packages:

rpm --checksig ripit-3.9.0-0.noarch.rpm

E.g. use YaST (by clicking on the rpm file) or zypper to install RipIT on the command line:

zypper install ripit-3.9.0-0.noarch.rpm

Or use the rpm-command for installation, i.e. type:

rpm -Uvh ripit-3.9.0-0.noarch.rpm

To install the source.rpm, then, for example, type

rpmbuild --target i686 --rebuild ripit-3.9.0-0.src.rpm

to get the ripit-3.9.0-0.noarch.rpm file.


Mandriva and other distributions

RPMs

One can find more rpms packed for different distros here. Thanks to Frank!


Debian packages

Debian packages of RipIt are to be found in the respective APT repositories for Etch, Lenny and Sid or can be downloaded from packages.debian.org.

To install the RipIT Debian package via APT, you should run the following commands as root in the shell:

apt-get update

apt-get install ripit



..::OLDER VERSIONS::..

The previous stable version of RipIT is 3.8.3 (released May 2nd 2010):


Tarballs

Older versions are to be found here.
Version 2.0 was the latest from Simon Quinn.
Version 2.4 was the latest from Mads Martin Jørgensen.


Last update: Nov 10th 2013 contact: ripit [_æt_] suwald [_ðöt_] com
v0.3
designed by phra:ha:d
© 2008 F. Suwald